Intermittent timeouts and slowness are identified in our EU communities

Incident Report for CC Status Page

Resolved

We have traced the root cause of the recent downtime to an AWS hardware failure. We apologize for the inconvenience this caused. Our team is already putting structural measures in place to ensure that similar hardware issues will not impact our platform going forward.
Posted Jul 08, 2026 - 13:54 CEST

Identified

Intermittent timeouts and slowness are identified in our EU communities. We identified the issue and are mitigating it. We will follow up and update this page as soon as we have more information.
Posted Jul 08, 2026 - 11:45 CEST
This incident affected: Status of our EMEA Community Infrastructure (Status of our EMEA Community Infrastructure).