US region degraded performance

Incident Report for CC Status Page

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 22:56 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2025 - 19:44 CEST

Update

We are continuing to work on a fix for this issue.
Posted Sep 03, 2025 - 19:44 CEST

Update

The root cause was identified, and the performance is back to expected performance. We will continue monitoring this incident.
Posted Sep 03, 2025 - 19:43 CEST

Identified

We identified a degraded performance especially on the homepages of our US communities. The investigation is ongoing into what is the root cause to this.
Posted Sep 03, 2025 - 18:49 CEST
This incident affected: Status of our US Community Infrastructure (Status of our US Community Infrastructure).